Template “base” utile per la configurazione di uno switch Cisco Catalyst con IOS 15

Gli obiettivi di questa configurazione sono: dare un nome e rendere raggiungibile lo switch dalla rete di management, sincronizzare l’orologio per una lettura dei log significativa, con un occhio alla sicurezza.

in corsivo i parametri modificabili dall’utente
in grassetto i comandi

Configurazione Hostname e Connettività

hostname switch
ip domain-name dominio.local
ip name-server 208.67.222.222
ip name-server 208.67.220.220

interface Vlan1
   description "VLAN NATIVA"
   ip address 192.168.1.253 255.255.255.0
   !

ip default-gateway 192.168.1.254

Configurazione Orologio

ntp server 193.204.114.232 prefer iburst
ntp server 193.204.114.233
ntp enable

Configurazione Time Zone e DST

clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00

Controllo di flusso e disabilitazione DTP

interface range GigabitEthernet 0/1-24
   flowcontrol receive desired
   switchport nonegotiate
   exit

Modifica alla community snmp public per renderla di sola lettura

snmp-server community public RO

Utente e Password

aaa new-model
username cisco privilege 15 secret 0 password

Accesso SSH

crypto key generate rsa
ip ssh version 2
ip ssh time-out 60
ip ssh authentication-retries 2
line vty 5 15
transport input ssh
end

Template “base” utile per la configurazione di uno switch HP ProCurve seguendo le Best Practice

Gli obiettivi di questa configurazione sono: dare un nome e rendere raggiungibile lo switch dalla rete di management, sincronizzare l’orologio per una lettura dei log significativa, con un occhio alla sicurezza e alla salute del layer fisico e di collegamento (L1 e L2).

in corsivo i parametri modificabili dall’utente
in grassetto i comandi

Configurazione Hostname e Connettività

hostname "switch"
ip dns domain-name "dominio.local"
ip dns server-address priority 1 208.67.222.222
ip dns server-address priority 2 208.67.220.220

vlan 1
   name "VLAN NATIVA"
   ip address 192.168.1.253 255.255.255.0
   exit

ip default-gateway 192.168.1.254

Configurazione Orologio

timesync ntp
ntp unicast
ntp server 193.204.114.232 iburst
ntp server 193.204.114.233
ntp enable

Configurazione Time Zone e DST

time daylight-time-rule user-defined begin-date 03/25 end-date 10/25
time timezone 60

Ricerca guasti

fault-finder all sensitivity high

Controllo di flusso e disabilitazione lacp

interface 1-28
   flow-control
   no lacp
   exit

Modifica alla community snmp public per renderla di sola lettura

snmp-server community "public" restricted

Abilitazione Spanning Tree

spanning-tree

Utente e Password

password manager password

Come configurare il servizio di sincronizzazione dell’orologio e impostare il cambio da ora legale CET ad ora solare CEST

Configurazione NTP usando i server italiani dell’Istituto Nazionale di Metereologia INRIM Time and Frequency Laboratory

timesync ntp
ntp unicast
ntp server 193.204.114.232 iburst
ntp server 193.204.114.233
ntp enable

Configurazione Time Zone e DST

time daylight-time-rule user-defined begin-date 03/25 end-date 10/25
time timezone 60

Verifica funzionamento

show ntp status

 NTP Status Information

  NTP Status             : Enabled         NTP Mode        : Unicast
  Synchronization Status : Synchronized    Peer Dispersion : 0.00000 sec
  Stratum Number         : 2               Leap Direction  : 0
  Reference Assoc ID     : 0               Clock Offset    : 35.52394 sec
  Reference ID           : 193.204.114...  Root Delay      : 0.02811 sec
  Precision              : 2**-18          Root Dispersion : 35.52907 sec
  NTP Up Time            : 0d 0h 6m        Time Resolution : 910 nsec
  Drift                  : 0.00000 sec/sec

  System Time            : Wed Nov  8 21:26:23 2017
  Reference Time         : Wed Nov  8 21:25:47 2017
show ntp associations

                            NTP Associations Entries


 Remote          St   T    When   Poll  Reach    Delay    Offset   Dispersion
 --------------- ---- ---- ------ ----- -------- -------- -------- ----------
 193.204.114.232 16        6      17    0        0.000    0.000    16.00000
 193.204.114.233 16        7      17    0        0.000    0.000    16.00000
show ntp statistics

 NTP Global statistics information

 NTP In Packets              : 1
 NTP Out Packets             : 1
 NTP Bad Version Packets     : 0
 NTP Protocol Error Packets  : 0
show time
  Wed Nov  8 21:26:23 2017

Come configurare il servizio semplificato di sincronizzazione dell’orologio e impostare il cambio da ora legale CET ad ora solare CEST

Configurazione SNTP usando i server italiani dell’Istituto Nazionale di Metereologia INRIM Time and Frequency Laboratory

timesync sntp
sntp unicast
sntp server priority 1 193.204.114.232
sntp server priority 2 193.204.114.233

Configurazione Time Zone e DST

time daylight-time-rule user-defined begin-date 03/25 end-date 10/25
time timezone 60

Verifica funzionamento

show sntp

 SNTP Configuration and Status

  Time Sync Mode      : SNTP

  SNTP Mode           : Unicast
  Poll Interval (sec) : 720
  SNTP Authentication : Disabled
  Source IP Selection : Outgoing Interface

  Priority SNTP Server Address                      Version Key-id
  -------- ---------------------------------------  ------- ----------
  1        193.204.114.232                          3       0
  2        193.204.114.233                          3       0
show sntp statistics

 SNTP Statistics

  Received Packets  : 4
  Sent Packets      : 7
  Dropped Packets   : 0

  SNTP Server Address                              Auth Failed Pkts
  ---------------------------------------          ----------------
  193.204.114.232                                      0
  193.204.114.233                                      0
show time
  Wed Nov  8 21:07:14 2017